Release-26.3.2.2 | QY

Scheduled for Sep 4, 05:00 - 06:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 03, 2026 - 13:23 CDT

Scheduled

We will be performing a scheduled release update on Friday, September 4, 2026, at 5:00 AM Central Time for release-26.3.2.2.

Affected modules: Quincy Video Visits / QuincyCHAT, Chat Widgets, Chatbots, and Quincy Forms.

During this release, users may experience brief interruptions or delayed access to the affected modules. We will update this status once the release is complete.
Posted Sep 03, 2026 - 13:22 CDT
This scheduled maintenance affects: Quincy (Quincy Chat Bots, Patient Chat, Quincy API).