RCA: Service Interruption – Database Transition Issue

Incident Report for QliqSOFT

Postmortem

Summary:
A service interruption occurred due to a database transition that resulted in some application nodes referencing an outdated database instance.

Root Cause:
During a database switchover, not all application nodes updated to the new database endpoint, leading to temporary inconsistencies in service behavior.

Resolution:
All affected nodes were restarted and reconnected to the correct database instance, resolving the issue at approximately 3:30 AM CST.

Current Status:
All systems are operating normally. We are continuing to monitor to ensure stability.

Posted Apr 27, 2026 - 10:48 CDT

Resolved

We experienced messaging delays along with inconsistencies in message status updates within the application. Some messages were not reflecting their correct delivery or read status in real time, and users may have also observed slower-than-normal message processing and updates across conversations.
Posted Apr 26, 2026 - 17:00 CDT